Problem in Jupyter Notebook (Sunpy)

Hi. I had some problems when I ran the sunpy module in my jupyter notebook. The problem is, I got some error which is “ImportError: erfa version 1.7 or later must be installed to use Astropy. erfa is not installed”. I was confused why this error could come because I already used the conda environment and all the module packages were successfully installed. Before this, it was okay and I could make the analysis go smoothly, but yesterday this error was coming suddenly and when I launched the environment from the Anaconda Navigator, it was like nothing happened like I had installed the conda environment before. It was really urgent because I need to make the analysis process for my presentation next week. Here, I provided some pictures for your references.

Hello Yieyn Cha,

I don’t see any images in your post?

What happens if you try to activate the environment in a terminal and try the notebook that way?

You could also install/update erfa and that would at least fix the original ImportError at the least. What side effects that could do, I am unsure.

Hello Nabobalis,

Firstly, I am really sorry for the late reply. My Anaconda Navigator cannot be opened suddenly even though I already shut down my laptop. Before this issue occurred, my conda environment cannot be run. I don’t know why this was occurred suddenly. It is because the module was being cracked or so on. The way that I solved this problem is by reinstalling the conda environment from the beginning. But, at the same time, I am scared that this problem will appear again next time.

I am glad that reinstalling environment worked out.

Working out what happened to the original one is going to be tricky.
Normally packages shouldn’t change in an environment without either updating the packages in it or installing new packages.